const regex = new RegExp('(>)()(<\\/)', 'gs')
const str = ` <file>
<fileType>Mezza</fileType>
<fileName></fileName>
<any_other_tag></any_other_tag>
<any_other_tag> </any_other_tag>
<segments>0000</segments>
</file>`;
const subst = `\1[!] value does not exist!\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);