// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)(>)()(<\/)").unwrap();
let string = " <file>
<fileType>Mezza</fileType>
<fileName></fileName>
<any_other_tag></any_other_tag>
<any_other_tag> </any_other_tag>
<segments>0000</segments>
</file>";
let substitution = "\\1[!] value does not exist!\\3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}