$re = '/(>)()(<\/)/s';
$str = ' <file>
<fileType>Mezza</fileType>
<fileName></fileName>
<any_other_tag></any_other_tag>
<any_other_tag> </any_other_tag>
<segments>0000</segments>
</file>';
$subst = "\1[!] value does not exist!\3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;