# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([a-zA-Z0-9-_.]*)@[a-zA-Z0-9-_.]*.gov{0,64}/$1,look i changed this/gm;t' <<< "john@president.gov
john1@president.gov
john-1@president.gov
Johnnnyboy@president.gov
betty@vicepres.com
dan-4@vicepres.net
thisisa64pluscharstringthisisa64pluscharstringthisisa64pluscharstring@thisisa64pluscharstring.com"