// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([a-zA-Z0-9-_.]*)@[a-zA-Z0-9-_.]*.gov{0,64}").unwrap();
let string = "john@president.gov
john1@president.gov
john-1@president.gov
Johnnnyboy@president.gov
betty@vicepres.com
dan-4@vicepres.net
thisisa64pluscharstringthisisa64pluscharstringthisisa64pluscharstring@thisisa64pluscharstring.com";
let substitution = "$1,look i changed this";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}