const regex = /([a-zA-Z0-9-_.]*)@[a-zA-Z0-9-_.]*.gov{0,64}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-zA-Z0-9-_.]*)@[a-zA-Z0-9-_.]*.gov{0,64}', 'gm')
const str = `john@president.gov
john1@president.gov
john-1@president.gov
Johnnnyboy@president.gov
betty@vicepres.com
dan-4@vicepres.net
thisisa64pluscharstringthisisa64pluscharstringthisisa64pluscharstring@thisisa64pluscharstring.com`;
const subst = `$1,look i changed this`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);