use strict;
my $str = 'john@president.gov
john1@president.gov
john-1@president.gov
Johnnnyboy@president.gov
betty@vicepres.com
dan-4@vicepres.net
thisisa64pluscharstringthisisa64pluscharstringthisisa64pluscharstring@thisisa64pluscharstring.com';
my $regex = qr/([a-zA-Z0-9-_.]*)@[a-zA-Z0-9-_.]*.gov{0,64}/mp;
my $subst = '$1,look i changed this';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";