package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([a-zA-Z0-9-_.]*)@[a-zA-Z0-9-_.]*.gov{0,64}`)
var str = `john@president.gov
john1@president.gov
john-1@president.gov
Johnnnyboy@president.gov
betty@vicepres.com
dan-4@vicepres.net
thisisa64pluscharstringthisisa64pluscharstringthisisa64pluscharstring@thisisa64pluscharstring.com`
var substitution = "$1,look i changed this"
fmt.Println(re.ReplaceAllString(str, substitution))
}