# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<img (.*) src="(.+?)".*>/<a href="$2" class="to"><img src="$2"><\/a>/is;t' <<< "<img style=\"display: block; margin-left: auto; margin-right: auto;\" src=\"/images/543 4352.png\" alt=\"\" width=\"750\" height=\"427\">
"