const regex = /<img (.*) src="(.+?)".*>/is;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<img (.*) src="(.+?)".*>', 'is')
const str = `<img style="display: block; margin-left: auto; margin-right: auto;" src="/images/543 4352.png" alt="" width="750" height="427">
`;
const subst = `<a href="$2" class="to"><img src="$2"></a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);