$re = '/<img (.*) src="(.+?)".*>/is';
$str = '<img style="display: block; margin-left: auto; margin-right: auto;" src="/images/543 4352.png" alt="" width="750" height="427">
';
$subst = "<a href=\"$2\" class=\"to\"><img src=\"$2\"></a>";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;