package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?is)<img (.*) src="(.+?)".*>`)
var str = []byte(`<img style="display: block; margin-left: auto; margin-right: auto;" src="/images/543 4352.png" alt="" width="750" height="427">
`)
var substitution = []byte("<a href="$2" class="to"><img src="$2"></a>")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}