# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<img (.*) src=\"(.+?)\".*>"
test_str = ("<img style=\"display: block; margin-left: auto; margin-right: auto;\" src=\"/images/543 4352.png\" alt=\"\" width=\"750\" height=\"427\">\n")
subst = "<a href=\"$2\" class=\"to\"><img src=\"$2\"></a>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1, re.IGNORECASE | re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.