const regex = new RegExp('[-*/+\\d]+', 'gm')
const str = `quanity*price/2+tax
quanity*price/2`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);