re = /[-*\/+\d]+/m
str = 'quanity*price/2+tax
quanity*price/2'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result