use strict;
my $str = 'quanity*price/2+tax
quanity*price/2';
my $regex = qr~[-*/+\d]+~mp;
my $subst = '\\n';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";