$re = '~[-*/+\d]+~m';
$str = 'quanity*price/2+tax
quanity*price/2';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;