package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"([^"]*)"`)
var str = `"Il cane è giallo" e mentre gli davo da mangiare "mi ha morso".`
var substitution = "“$1”"
fmt.Println(re.ReplaceAllString(str, substitution))
}