use strict;
my $str = '"Il cane è giallo" e mentre gli davo da mangiare "mi ha morso".';
my $regex = qr/"([^"]*)"/mp;
my $subst = '“$1”';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";