re = /"([^"]*)"/m
str = '"Il cane è giallo" e mentre gli davo da mangiare "mi ha morso".'
subst = '“$1”'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result