$re = '/"([^"]*)"/m';
$str = '"Il cane è giallo" e mentre gli davo da mangiare "mi ha morso".';
$subst = "“$1”";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;