#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "Privileges: (?<Privilege>[^ ]*)"
Local $sString = "Subject:" & @CRLF & _
"" & @CRLF & _
"Security ID: WIN-R9H529RIO4Y\Administrator" & @CRLF & _
"Account Name: Administrator" & @CRLF & _
"Account Domain: WIN-R9H529RIO4Y" & @CRLF & _
"Logon ID: 0x4b842" & @CRLF & _
"" & @CRLF & _
"Privileges: SeSecurityPrivilege" & @CRLF & _
"SeTakeOwnershipPrivilege" & @CRLF & _
"SeLoadDriverPrivilege" & @CRLF & _
"SeBackupPrivilege" & @CRLF & _
"SeRestorePrivilege" & @CRLF & _
"SeDebugPrivilege" & @CRLF & _
"SeSystemEnvironmentPrivilege" & @CRLF & _
"SeImpersonatePrivilege"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")