import re
regex = re.compile(r"Privileges: (?<Privilege>[^ ]*)")
test_str = ("Subject:\n\n"
"Security ID: WIN-R9H529RIO4Y\\Administrator\n"
"Account Name: Administrator\n"
"Account Domain: WIN-R9H529RIO4Y\n"
"Logon ID: 0x4b842\n\n"
"Privileges: SeSecurityPrivilege\n"
"SeTakeOwnershipPrivilege\n"
"SeLoadDriverPrivilege\n"
"SeBackupPrivilege\n"
"SeRestorePrivilege\n"
"SeDebugPrivilege\n"
"SeSystemEnvironmentPrivilege\n"
"SeImpersonatePrivilege")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")