import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Privileges: (?<Privilege>[^ ]*)";
final String string = "Subject:\n\n"
+ "Security ID: WIN-R9H529RIO4Y\\Administrator\n"
+ "Account Name: Administrator\n"
+ "Account Domain: WIN-R9H529RIO4Y\n"
+ "Logon ID: 0x4b842\n\n"
+ "Privileges: SeSecurityPrivilege\n"
+ "SeTakeOwnershipPrivilege\n"
+ "SeLoadDriverPrivilege\n"
+ "SeBackupPrivilege\n"
+ "SeRestorePrivilege\n"
+ "SeDebugPrivilege\n"
+ "SeSystemEnvironmentPrivilege\n"
+ "SeImpersonatePrivilege";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}