package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Privileges: (?<Privilege>[^ ]*)`)
var str = `Subject:
Security ID: WIN-R9H529RIO4Y\Administrator
Account Name: Administrator
Account Domain: WIN-R9H529RIO4Y
Logon ID: 0x4b842
Privileges: SeSecurityPrivilege
SeTakeOwnershipPrivilege
SeLoadDriverPrivilege
SeBackupPrivilege
SeRestorePrivilege
SeDebugPrivilege
SeSystemEnvironmentPrivilege
SeImpersonatePrivilege`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}