# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?!.*?(?-i:that)).*$//gmi;t' <<< "I like this sentence.
I like that sentence.
I link THAT sentence."