const regex = /^(?!.*?(?-i:that)).*$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*?(?-i:that)).*$', 'gmi')
const str = `I like this sentence.
I like that sentence.
I link THAT sentence.`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);