$re = '/^(?!.*?(?-i:that)).*$/mi';
$str = 'I like this sentence.
I like that sentence.
I link THAT sentence.';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;