#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)^(?!.*?(?-i:that)).*$"
Local $sString = "I like this sentence." & @CRLF & _
"I like that sentence." & @CRLF & _
"I link THAT sentence."
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)