re = /^(?!.*?(?-i:that)).*$/mi
str = 'I like this sentence.
I like that sentence.
I link THAT sentence.'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result