using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"INV(?<invnr>\d+)";
string input = @" Danke für das Zahlen der Rechnung INV1101 DATUM 16.02.2021, 08.58 UHR";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}