// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)INV(?<invnr>\d+)").unwrap();
let string = " Danke für das Zahlen der Rechnung INV1101 DATUM 16.02.2021, 08.58 UHR";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}