package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)INV(?<invnr>\d+)`)
var str = ` Danke für das Zahlen der Rechnung INV1101 DATUM 16.02.2021, 08.58 UHR`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}