re = /INV(?<invnr>\d+)/m
str = ' Danke für das Zahlen der Rechnung INV1101 DATUM 16.02.2021, 08.58 UHR'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end