$re = '/INV(?<invnr>\d+)/m';
$str = ' Danke für das Zahlen der Rechnung INV1101 DATUM 16.02.2021, 08.58 UHR';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);