using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?:kill_query|""kill_query"")[\ ]*\([\ ]*'([\w_-]*)'|(?:query_id[\ ]*=>[\ ]*'([\w_-]*)'))";
string input = @"CALL system.runtime.kill_query(query_id => '20211003_215635_15007_n3mb3', message => 'Looker query cancel.')
CALL ""system"".""runtime"".""kill_query""(query_id => '20211003_215635_15007_n3mb3', message => 'Looker query cancel.')
CALL ""system"".runtime.""kill_query""(query_id => '20211003_215635_15007_n3mb3', message => 'Looker query cancel.')
CALL ""system"".""runtime"".""kill_query""('20211003_215635_15007_n3mb3', 'afsd')
CALL ""system"".""runtime"".""kill_query""(message => '20211003_215635_15007_n3mb3', query_id => 'afsd')
CALL ""system"".""runtime"".""kill_query""(message => '20211003_215635_15007_n3mb3', query_id => 'afsd')";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}