re = /(?:(?:kill_query|"kill_query")[\ ]*\([\ ]*'([\w_-]*)'|(?:query_id[\ ]*=>[\ ]*'([\w_-]*)'))/m
str = 'CALL system.runtime.kill_query(query_id => \'20211003_215635_15007_n3mb3\', message => \'Looker query cancel.\')
CALL "system"."runtime"."kill_query"(query_id => \'20211003_215635_15007_n3mb3\', message => \'Looker query cancel.\')
CALL "system".runtime."kill_query"(query_id => \'20211003_215635_15007_n3mb3\', message => \'Looker query cancel.\')
CALL "system"."runtime"."kill_query"(\'20211003_215635_15007_n3mb3\', \'afsd\')
CALL "system"."runtime"."kill_query"(message => \'20211003_215635_15007_n3mb3\', query_id => \'afsd\')
CALL "system"."runtime"."kill_query"(message => \'20211003_215635_15007_n3mb3\', query_id => \'afsd\')'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end