import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?:kill_query|\"kill_query\")[\\ ]*\\([\\ ]*'([\\w_-]*)'|(?:query_id[\\ ]*=>[\\ ]*'([\\w_-]*)'))";
final String string = "CALL system.runtime.kill_query(query_id => '20211003_215635_15007_n3mb3', message => 'Looker query cancel.')\n\n"
+ "CALL \"system\".\"runtime\".\"kill_query\"(query_id => '20211003_215635_15007_n3mb3', message => 'Looker query cancel.')\n\n\n\n"
+ "CALL \"system\".runtime.\"kill_query\"(query_id => '20211003_215635_15007_n3mb3', message => 'Looker query cancel.')\n\n\n"
+ "CALL \"system\".\"runtime\".\"kill_query\"('20211003_215635_15007_n3mb3', 'afsd')\n\n\n\n"
+ "CALL \"system\".\"runtime\".\"kill_query\"(message => '20211003_215635_15007_n3mb3', query_id => 'afsd')\n\n"
+ "CALL \"system\".\"runtime\".\"kill_query\"(message => '20211003_215635_15007_n3mb3', query_id => 'afsd')";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}