const regex = /(?:(?:kill_query|"kill_query")[\ ]*\([\ ]*'([\w_-]*)'|(?:query_id[\ ]*=>[\ ]*'([\w_-]*)'))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?:kill_query|"kill_query")[\\ ]*\\([\\ ]*\'([\\w_-]*)\'|(?:query_id[\\ ]*=>[\\ ]*\'([\\w_-]*)\'))', 'gm')
const str = `CALL system.runtime.kill_query(query_id => '20211003_215635_15007_n3mb3', message => 'Looker query cancel.')
CALL "system"."runtime"."kill_query"(query_id => '20211003_215635_15007_n3mb3', message => 'Looker query cancel.')
CALL "system".runtime."kill_query"(query_id => '20211003_215635_15007_n3mb3', message => 'Looker query cancel.')
CALL "system"."runtime"."kill_query"('20211003_215635_15007_n3mb3', 'afsd')
CALL "system"."runtime"."kill_query"(message => '20211003_215635_15007_n3mb3', query_id => 'afsd')
CALL "system"."runtime"."kill_query"(message => '20211003_215635_15007_n3mb3', query_id => 'afsd')`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}