import re
regex = re.compile(r"(?:(?:kill_query|\"kill_query\")[\ ]*\([\ ]*'([\w_-]*)'|(?:query_id[\ ]*=>[\ ]*'([\w_-]*)'))", flags=re.MULTILINE)
test_str = ("CALL system.runtime.kill_query(query_id => '20211003_215635_15007_n3mb3', message => 'Looker query cancel.')\n\n"
"CALL \"system\".\"runtime\".\"kill_query\"(query_id => '20211003_215635_15007_n3mb3', message => 'Looker query cancel.')\n\n\n\n"
"CALL \"system\".runtime.\"kill_query\"(query_id => '20211003_215635_15007_n3mb3', message => 'Looker query cancel.')\n\n\n"
"CALL \"system\".\"runtime\".\"kill_query\"('20211003_215635_15007_n3mb3', 'afsd')\n\n\n\n"
"CALL \"system\".\"runtime\".\"kill_query\"(message => '20211003_215635_15007_n3mb3', query_id => 'afsd')\n\n"
"CALL \"system\".\"runtime\".\"kill_query\"(message => '20211003_215635_15007_n3mb3', query_id => 'afsd')")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")