using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\S)(?:(@[^\s@]+)(?!\S)[^h]*(?:h(?!ttp)[^h]*)*+)?\K((?:https?|ftp|file)://\S+)";
string substitution = @"";
string input = @"@test https://stackoverflow.com/questions/ask
Hello @username you need to check this http://github.com and @username you need to https://stackoverflow.com/questions/ask
This is an email test@test.com http://www.test.test
Hello @username you need to check this htt://github.com and @username you need to
Hello @username check this https://regex101.com/r/D3Imn9/1";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}