const regex = new RegExp('(?<!\\S)(?:(@[^\\s@]+)(?!\\S)[^h]*(?:h(?!ttp)[^h]*)*+)?\\K((?:https?|ftp|file)://\\S+)', 'gm')
const str = `@test https://stackoverflow.com/questions/ask
Hello @username you need to check this http://github.com and @username you need to https://stackoverflow.com/questions/ask
This is an email test@test.com http://www.test.test
Hello @username you need to check this htt://github.com and @username you need to
Hello @username check this https://regex101.com/r/D3Imn9/1`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);