import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\S)(?:(@[^\\s@]+)(?!\\S)[^h]*(?:h(?!ttp)[^h]*)*+)?\\K((?:https?|ftp|file)://\\S+)";
final String string = "@test https://stackoverflow.com/questions/ask\n\n\n"
+ "Hello @username you need to check this http://github.com and @username you need to https://stackoverflow.com/questions/ask\n\n"
+ "This is an email test@test.com http://www.test.test\n\n\n"
+ "Hello @username you need to check this htt://github.com and @username you need to \n\n"
+ "Hello @username check this https://regex101.com/r/D3Imn9/1";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}