#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^0-9-_][A-z0-9.-]+@[A-z.-]+.[A-z]+$"
Local $sString = "emreyl.___yldrm@yandex.com" & @CRLF & _
"emMMreylyl_yl@gmail.com" & @CRLF & _
"emMMreylyl-yl@gmail.com" & @CRLF & _
"emreyl.yldrm@yandex.comkuuyv" & @CRLF & _
"_9emreyl.yldrm@yandex.co__m" & @CRLF & _
"-9emreyl.yldrm@yandex.co__m" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")