# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[^0-9-_][A-z0-9.-]+@[A-z.-]+.[A-z]+$"
test_str = ("emreyl.___yldrm@yandex.com\n"
"emMMreylyl_yl@gmail.com\n"
"emMMreylyl-yl@gmail.com\n"
"emreyl.yldrm@yandex.comkuuyv\n"
"_9emreyl.yldrm@yandex.co__m\n"
"-9emreyl.yldrm@yandex.co__m\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.