package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^0-9-_][A-z0-9.-]+@[A-z.-]+.[A-z]+$`)
var str = `emreyl.___yldrm@yandex.com
emMMreylyl_yl@gmail.com
emMMreylyl-yl@gmail.com
emreyl.yldrm@yandex.comkuuyv
_9emreyl.yldrm@yandex.co__m
-9emreyl.yldrm@yandex.co__m
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}