$re = '/^[^0-9-_][A-z0-9.-]+@[A-z.-]+.[A-z]+$/m';
$str = 'emreyl.___yldrm@yandex.com
emMMreylyl_yl@gmail.com
emMMreylyl-yl@gmail.com
emreyl.yldrm@yandex.comkuuyv
_9emreyl.yldrm@yandex.co__m
-9emreyl.yldrm@yandex.co__m
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);