using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^0-9-_][A-z0-9.-]+@[A-z.-]+.[A-z]+$";
string input = @"emreyl.___yldrm@yandex.com
emMMreylyl_yl@gmail.com
emMMreylyl-yl@gmail.com
emreyl.yldrm@yandex.comkuuyv
_9emreyl.yldrm@yandex.co__m
-9emreyl.yldrm@yandex.co__m
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}