import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "name=\"(.*?)\" value=\"(.*?)\"";
final String string = "<input type=\"hidden\" name=\"jazoest\" value=\"2703\" autocomplete=\"off\">\n"
+ "<input type=\"hidden\" autocomplete=\"off\" name=\"timezone\" value=\"180\" id=\"u_0_9\">";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}