re = /name="(.*?)" value="(.*?)"/i
str = '<input type="hidden" name="jazoest" value="2703" autocomplete="off">
<input type="hidden" autocomplete="off" name="timezone" value="180" id="u_0_9">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end